Why is my point cloud not colored?
  • 15 Oct 2024
  • 1 Minute to read
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Why is my point cloud not colored?

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Article summary

Introduction

Problem description

As a user, one might find the processed Point cloud does not show color, when opening in 3rd party software.

Scope

Solution applies to NavVis Desktop Processing.

Troubleshooting procedure

Root cause

  • Not enough valid images in the post-processing stage.

  • Colorize point clouds option was not selected in the processing setting.

1 Check in the datasets_rec/2021-xx-xx/cam folder

  • If there are enough images that correspond to the numbering of info files under datasets_proc/2021-xx-xx/info.

  • If there are not enough cam images, then the point cloud coloring stage will not have enough data to execute the colorization process.

2 Check Colorize point clouds

Check if the Colorize point clouds option was selected in SiteMaker or the Colorized option in cloud processing configurations.

3 Check which point cloud

Check which point cloud you're using:

  • Datasets_proc/2021-08-21_15.56.33/pointcloud.e57 or pointcloud.ply -> should have color usually

  • 2021-08-21_15.56.33/pointclouds/pointcloud-raw.e57 or pointcloud-raw.ply -> does not contain color information

Reference


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