Why is my SSD not recognized?
  • 11 Mar 2024
  • 2 Minutes to read
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Why is my SSD not recognized?

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Article summary

Introduction

Problem description

When switching on the device, it display an error message like this:

[13:28:38]  Failed to prepare mapping:

[Errno  13]  Permission denied:  '/srv/data'

Or it warns even before you can start the UI:

 Could not find a usable SSD

Scope

This solution applies to the NavVis M6 and NavVis VLX.

Root cause

  1. SSD is not mounted and not set up

  2. SSD is mounted but not set up

  3. SSD is set up but not mounted

  4. If the above options are not true then SSD might be corrupted 

Troubleshooting procedure

Solution 1: The SSD mount spot is occupied

Disconnect the SSD and see if there is still a \srv folder available. If yes you can delete it with the following command:

sudo rm -rf \srv

Afterwards, connect the SSD again to mount it.

Solution 2: Check that it is mounted

To check if it's mounted, you could open the "Disks" application from the system, and search for the external SSD disk. 

If it's not mounted, it will show "Not Mounted" in the "Contents" field. Also the Volume will have an icon like a "Play" button.

Press the "Play" button to mount it.

 

Solution 3: The SSD is not set up

If the SSD is mounted but not set up, or if the SSD itself is corrupted, please refer to our documentations how to set up the disk in correct formats and folder structures.

Please make sure that your SSD is named/labeled as "data" and not "DATA". 

Please considering following our documentation on formatting the disk to exfat, so it can be recognized across different operating systems.

Solution 4 (NavVis M6): The SSD is not recognized

If you have first booted up the device and then inserted the SSD , it can happen that it is not recognized. Simply try restarting the NavVis M6 with the SSD inserted.

Solution 5 (NavVis VLX): The SSD was not properly inserted

If the SSD is not found in the Disks application in Ubuntu then it can happen that the customer has not plugged the SSD well into the SSD slot on the NavVis VLX. You can try to connect the SSD via cable to the USB slot in the device and check if the SSD is operational. Also, the T5 SSD shipped with the NavVis VLX should stick out exactly 30mm from the device. Tell the customer to measure it and if it is even a few mm over 30 then it is not inserted well. Let the customer move the SSD around until fully inserted.

If the SSD was never used in a NavVis VLX before, open a terminal and run navvis-mapping-ui which should open the Mapping UI and set up the needed folders on the SSD. Rename the SSD via the Disk utility to "data" in order to be successfully recognized by your NavVis VLX.


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